summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2008-03-21 15:47:51 +0000
committerthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2008-03-21 15:47:51 +0000
commit0e8595603e1c62815d91baac98c71a2893df174f (patch)
treef4795ebede60cf6b530523e09762348926847735 /Makefile.am
parentb9c61819ac94e88385b801cdd5799057ae591513 (diff)
downloadmpc-0e8595603e1c62815d91baac98c71a2893df174f.tar.gz
Merged feature-autotools branch changes r72:r76 into the trunk.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@77 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c11c285
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+include_HEADERS = mpc.h
+
+lib_LTLIBRARIES = libmpc.la
+libmpc_la_SOURCES = mpc-impl.h abs.c add.c add_fr.c add_ui.c clear.c \
+cmp.c cmp_si_si.c conj.c div_2exp.c div.c div_fr.c div_ui.c exp.c \
+get_prec2.c get_prec.c init2.c init3.c init.c inp_str.c mul_2exp.c mul.c \
+mul_fr.c mul_i.c mul_si.c mul_ui.c neg.c norm.c out_str.c random2.c random.c \
+set.c set_d_d.c set_dfl_prec.c set_prec.c set_si_si.c set_ui_fr.c \
+set_ui_ui.c sin.c sqr.c sqrt.c sub.c sub_ui.c uceil_log2.c ui_div.c \
+ui_ui_sub.c
+
+LDADD = $(top_builddir)/libmpc.la
+
+check_INCLUDES = -I$(top_srcdir)
+check_PROGRAMS = test tabs tdiv texp tmul tsin tsqr
+
+TESTS = $(check_PROGRAMS)
+CLEANFILES = $(top_builddir)/mpc_test
+
+info_TEXINFOS = mpc.texi