summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-02-21 16:41:09 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-02-21 16:41:09 +0000
commit204f6d70eba9985a3767e594bd8fd9849730c146 (patch)
treec0bd1a014afe4e44b058e14726878ffeaab91c4c /configure.ac
parent4de67b01623061e08b137acca3fa711df4d1d9cc (diff)
downloadmpc-204f6d70eba9985a3767e594bd8fd9849730c146.tar.gz
configure.ac: call AC_PROG_LIBTOOL earlier so that it checks for egrep
(see http://lists.gforge.inria.fr/pipermail/mpc-discuss/2011-February/000805.html) git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@936 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 11 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 45dcb43..ffbcfbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@ AM_MAINTAINER_MODE
AC_CANONICAL_HOST
AC_CONFIG_MACRO_DIR([m4])
-dnl Extra arguments to configure
+# Extra arguments to configure
AC_ARG_WITH([mpfr_include],
[AC_HELP_STRING([--with-mpfr-include=DIR],
[MPFR include directory])],
@@ -85,18 +85,19 @@ AC_ARG_ENABLE([logging],
)
-dnl Setup CC and CFLAGS
+# Setup CC and CFLAGS
+AC_PROG_CC
+AC_LANG(C)
-dnl Check for user specification of CC or CFLAGS
+# Set up LibTool
+AC_PROG_LIBTOOL
+
+# Check for user specification of CC or CFLAGS
if test -n "$CFLAGS" || test -n "$CC" ; then
user_redefine_cc=yes
fi
-# Check for programs
-AC_PROG_CC
-AC_LANG(C)
-
-dnl Check GMP Header
+# Check GMP Header
AC_MSG_CHECKING(for gmp.h)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
#include "gmp.h"
@@ -105,22 +106,19 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
AC_MSG_ERROR([gmp.h can't be found, or is unusable.])
])
-dnl Check for GMP CFLAGS in gmp.h
+# Check for GMP CFLAGS in gmp.h
if test -z "$user_redefine_cc" ; then
MPC_GMP_CC_CFLAGS
fi
-dnl Configs for Windows DLLs
+# Configs for Windows DLLs
case $host in
*-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
MPC_WINDOWS
esac
-dnl Finally set up LibTool
-AC_PROG_LIBTOOL
-
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([complex.h locale.h inttypes.h stdint.h limits.h unistd.h sys/time.h])