summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-26 12:27:20 +0000
committerzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-26 12:27:20 +0000
commit4dc0c50f08d9b51a69980054a10d20e9f8609704 (patch)
treefefa786c39f5c353a0075c6441d201923d0c5d89 /configure.ac
parent870036d256ee38f97646cd937406cf76ed643f25 (diff)
downloadmpc-4dc0c50f08d9b51a69980054a10d20e9f8609704.tar.gz
[configure.ac] added comments why we require GMP >= 4.2 and MPFR >= 2.3.1
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@507 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9d070d2..9120c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,7 +213,8 @@ AC_LINK_IFELSE(
AC_MSG_ERROR([libmpfr not found or uses a different ABI.])
])
-# Check for a recent GMP
+# Check for a recent GMP: we need GMP 4.2 because we use the
+# mp_get_memory_functions which appeared in GMP 4.2
AC_MSG_CHECKING(for recent GMP)
AC_COMPILE_IFELSE(
[AC_LANG_SOURCE(
@@ -230,7 +231,9 @@ error
AC_MSG_ERROR([GMP version >= 4.2 required])
])
-# Check for a recent MPFR
+# Check for a recent MPFR: we require MPFR 2.3.1 because of a bug in
+# mpfr_div_ui which makes mpc_div_ui returns the wrong sign of the zero part
+# when applied on a pure real or pure imaginary parameter (see mpfr r4950)
AC_MSG_CHECKING(for recent MPFR)
AC_COMPILE_IFELSE(
[AC_LANG_SOURCE(