summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2010-10-04 15:01:30 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2010-10-04 15:01:30 +0000
commit5412050c15c366785e271b0e2dfb46db7473cd3e (patch)
treea46919ece074ae7a0dd590c5936ed43d61414a92 /configure.ac
parentc79b7a91bf69697a7db1281b7248c21803f2a53a (diff)
downloadmpc-5412050c15c366785e271b0e2dfb46db7473cd3e.tar.gz
increased minimal version requirements to gmp 4.3.2 and mpfr 2.4.2
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@844 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 66f66f3..33c1869 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,34 +132,33 @@ AC_COMPILE_IFELSE(
[AC_LANG_SOURCE(
[[
#include "gmp.h"
-#if (__GNU_MP_VERSION*100 + __GNU_MP_VERSION_MINOR*10 + __GNU_MP_VERSION_PATCHLEVEL < 420)
-# error "Minimal GMP version is 4.2"
+#if (__GNU_MP_VERSION*100 + __GNU_MP_VERSION_MINOR*10 + __GNU_MP_VERSION_PATCHLEVEL < 432)
+# error "Minimal GMP version is 4.3.2"
error
#endif
]])],
[AC_MSG_RESULT(yes)],
[
AC_MSG_RESULT(no)
- AC_MSG_ERROR([GMP version >= 4.2 required])
+ AC_MSG_ERROR([GMP version >= 4.3.2 required])
])
-# Check for a recent MPFR: we require MPFR 2.3.1 because of a bug in
-# mpfr_div_ui which makes mpc_div_ui return the wrong sign of the zero part
-# when applied on a pure real or pure imaginary parameter (see mpfr r4950)
+# Check for a recent MPFR: we require MPFR 2.4.2 so that the tests
+# in log.dat pass
AC_MSG_CHECKING(for recent MPFR)
AC_COMPILE_IFELSE(
[AC_LANG_SOURCE(
[[
#include "mpfr.h"
-#if (MPFR_VERSION < MPFR_VERSION_NUM (2,3,1))
-# error "Minimal MPFR version is 2.3.1"
+#if (MPFR_VERSION < MPFR_VERSION_NUM (2,4,2))
+# error "Minimal MPFR version is 2.4.2"
error
#endif
]])],
[AC_MSG_RESULT(yes)],
[
AC_MSG_RESULT(no)
- AC_MSG_ERROR([MPFR version >= 2.3.1 required])
+ AC_MSG_ERROR([MPFR version >= 2.4.2 required])
])
# Checks for header files.