summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-27 10:23:32 +0000
committerzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-27 10:23:32 +0000
commit5c9187b52336154d3cb5195f45b99c80e5097d24 (patch)
tree8a190343aae977bc4ef3dacf964f96e38f1212ac /configure.ac
parentd8d8a0e6caf163cbffa9d1f2beb4c6c7d2e2bdb9 (diff)
downloadmpc-5c9187b52336154d3cb5195f45b99c80e5097d24.tar.gz
[configure.ac] minimal GMP version is now 4.1.3 instead of 4.2
[mem.c] new wrapper file for mp_get_memory_functions (not in GMP 4.1.3) [get_str.c,inp_str.c] moved mp_get_memory_functions to mem.c [tests/tset.c,tests/random.c] added wrappers for gmp_random functions (not in GMP 4.1.3) git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@509 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5bc391d..ee1001d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,25 +213,26 @@ AC_LINK_IFELSE(
AC_MSG_ERROR([libmpfr not found or uses a different ABI.])
])
-# Check for a recent GMP: we need GMP 4.2 because we use the
-# mp_get_memory_functions which appeared in GMP 4.2.
-# Note also that GMP 4.1.1 does not compile on Core 2 with gcc 4.3.2:
+# Check for a recent GMP: we need GMP 4.1.3 because GMP 4.1.2 fails to compile
+# on Core 2 with gcc 4.3.2 for example:
# dive_1.c:89: Error: Incorrect register `%edi' used with `q' suffix
-# (a fix was introduced in GMP 4.1.3)
+# Once we upgrade the minimal GMP version to GMP 4.2, we can simplify the code
+# using mp_get_memory_functions in mem.c and that using the gmp_random
+# functions in tests/random.c
AC_MSG_CHECKING(for recent GMP)
AC_COMPILE_IFELSE(
[AC_LANG_SOURCE(
[[
#include "gmp.h"
-#if (__GNU_MP_VERSION*100 + __GNU_MP_VERSION_MINOR*10 < 420)
-# error "min GMP version is 4.2"
+#if (__GNU_MP_VERSION*100 + __GNU_MP_VERSION_MINOR*10 + __GNU_MP_VERSION_PATCHLEVEL < 413)
+# error "min GMP version is 4.1.3"
error
#endif
]])],
[AC_MSG_RESULT(yes)],
[
AC_MSG_RESULT(no)
- AC_MSG_ERROR([GMP version >= 4.2 required])
+ AC_MSG_ERROR([GMP version >= 4.1.3 required])
])
# Check for a recent MPFR: we require MPFR 2.3.1 because of a bug in