summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2008-11-20 14:47:06 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2008-11-20 14:47:06 +0000
commit7b11f549be63b59af9a2d29a303166be73fd16a4 (patch)
treecacde65878525b27a03d3fe124bae7c0d3fa020e /configure.ac
parentf682c3c7e6a253397d75ebe54082dd488a81454a (diff)
downloadmpc-7b11f549be63b59af9a2d29a303166be73fd16a4.tar.gz
added some messages
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@350 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fbb47fd..b011668 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,14 +86,18 @@ AC_CHECK_LIB([gmp], [__gmpz_init],
#AC_CHECK_LIB([mpfr], [mpfr_init],
# [LIBS="-lmpfr $LIBS"],
# [AC_MSG_ERROR([libmpfr not found or uses a different ABI.])])
+AC_MSG_CHECKING(for MPFR)
LIBS="-lmpfr $LIBS"
AC_LINK_IFELSE(
[AC_LANG_PROGRAM(
[[#include "mpfr.h"]],
[[mpfr_t x; mpfr_init(x) ; mpfr_clear(x);]]
)],
- [],
- [AC_MSG_ERROR([libmpfr not found or uses a different ABI.])])
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([libmpfr not found or uses a different ABI.])
+ ])
# Check for a recent GMP
AC_MSG_CHECKING(for recent GMP)