summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2012-07-23 11:56:52 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2012-07-23 11:56:52 +0000
commita0fdd560167ff7e18abf916ebb9ef284ef141e37 (patch)
treeb522b3ace606be82670dad5c0b02948fc34574ee /configure.ac
parent1d835d49bcdc76246ae5321648aa25351e7da602 (diff)
downloadmpc-a0fdd560167ff7e18abf916ebb9ef284ef141e37.tar.gz
require mpfr >= 3.0.0
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@1245 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9cd8d0f..4d4603a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,23 +187,22 @@ error
AC_MSG_ERROR([GMP version >= 4.3.2 required])
])
-# Check for a recent MPFR: we require MPFR 2.4.2 so that the tests
-# in log.dat pass
+# Check for a recent MPFR: we require MPFR 3.0.0 for MPC_RNDA
# The same remark as above for GMP applies.
AC_MSG_CHECKING(for recent MPFR)
AC_COMPILE_IFELSE(
[AC_LANG_SOURCE(
[[
#include "mpfr.h"
-#if (MPFR_VERSION < MPFR_VERSION_NUM (2,4,2))
-# error "Minimal MPFR version is 2.4.2"
+#if (MPFR_VERSION < MPFR_VERSION_NUM (3,0,0))
+# error "Minimal MPFR version is 3.0.0"
error
#endif
]])],
[AC_MSG_RESULT(yes)],
[
AC_MSG_RESULT(no)
- AC_MSG_ERROR([MPFR version >= 2.4.2 required])
+ AC_MSG_ERROR([MPFR version >= 3.0.0 required])
])
# Check for logging feature