summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-17 17:50:22 +0000
committerthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-17 17:50:22 +0000
commitaa5cf4f74446601e854f3841a0aab74e9fa229f5 (patch)
treecd05037f157f0df5b14c0c45873128960d3c8be2 /configure.ac
parent9dd0f23159d01367a93776126415607fd52decd9 (diff)
downloadmpc-aa5cf4f74446601e854f3841a0aab74e9fa229f5.tar.gz
revert to UNIX format (r457 changed every file to DOS format).
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@459 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac394
1 files changed, 197 insertions, 197 deletions
diff --git a/configure.ac b/configure.ac
index 48c040c..8a50c35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,197 +1,197 @@
-/* configure.ac
-
-Copyright (C) 2008, 2009 Andreas Enge, Philippe Th\'eveny
-
-This file is part of the MPC Library.
-
-The MPC Library is free software; you can redistribute it and/or modify
-it under the terms of the GNU Lesser General Public License as published by
-the Free Software Foundation; either version 2.1 of the License, or (at your
-option) any later version.
-
-The MPC Library is distributed in the hope that it will be useful, but
-WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
-or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public
-License for more details.
-
-You should have received a copy of the GNU Lesser General Public License
-along with the MPC Library; see the file COPYING.LIB. If not, write to
-the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
-MA 02111-1307, USA. */
-
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.61)
-AC_INIT(mpc, 0.6-dev, mpc-discuss@lists.gforge.inria.fr)
-AC_CONFIG_SRCDIR([src/mpc-impl.h])
-AC_CONFIG_HEADER([config.h])
-
-AM_INIT_AUTOMAKE([1.9 -Wall -Werror])
-AM_MAINTAINER_MODE
-
-dnl Extra arguments to configure
-AC_ARG_WITH([mpfr_include],
- [AC_HELP_STRING([--with-mpfr-include=DIR],
- [MPFR include directory])],
- [CPPFLAGS="-I$withval $CPPFLAGS"])
-AC_ARG_WITH([mpfr_lib],
- [AC_HELP_STRING([--with-mpfr-lib=DIR],
- [MPFR lib directory])],
- [LDFLAGS="-L$withval $LDFLAGS"])
-AC_ARG_WITH([mpfr],
- [AC_HELP_STRING([--with-mpfr=DIR],
- [MPFR install directory])],
- [
- CPPFLAGS="-I$withval/include $CPPFLAGS"
- LDFLAGS="-L$withval/lib $LDFLAGS"
- ])
-AC_ARG_WITH([gmp_include],
- [AC_HELP_STRING([--with-gmp-include=DIR],
- [GMP include directory])],
- [CPPFLAGS="-I$withval $CPPFLAGS"])
-AC_ARG_WITH([gmp_lib],
- [AC_HELP_STRING([--with-gmp-lib=DIR],
- [GMP lib directory])],
- [LDFLAGS="-L$withval $LDFLAGS"])
-AC_ARG_WITH([gmp],
- [AC_HELP_STRING([--with-gmp=DIR],
- [GMP install directory])],
- [
- CPPFLAGS="-I$withval/include $CPPFLAGS"
- LDFLAGS="-L$withval/lib $LDFLAGS"
- ])
-AC_ARG_VAR([MPC_USE_LOGGING], [defined if logging support wanted])
-AC_ARG_ENABLE([logging],
- [AC_HELP_STRING([--enable-logging],
- [enable MPC logging [default=no]])],
- [
- case $enableval in
- yes) AC_DEFINE([MPC_USE_LOGGING],1,[Logging support]) ;;
- no) ;;
- *) AC_MSG_ERROR([bad value for --enable-logging: yes or no])
- ;;
- esac
- ])
-
-# Checks for programs.
-AC_PROG_CC
-AC_PROG_SED
-case $host in
- *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
- AC_MSG_CHECKING(for DLL/static GMP)
- if test "$enable_shared" = yes; then
- LDFLAGS="$LDFLAGS -no-undefined"
- dont_link_with_gmp="yes"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "gmp.h"
-#if !__GMP_LIBGMP_DLL
-# error "Dead man"
-error
-#endif
- ]], [[]])],[AC_MSG_RESULT(DLL)],[
- AC_MSG_RESULT(static)
- AC_MSG_ERROR([gmp.h isn't a DLL: use --enable-static --disable-shared]) ])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "mpfr.h"
-#if !__GMP_LIBGMP_DLL
-# error "Dead man"
-error
-#endif
- ]], [[]])],[AC_MSG_RESULT(DLL)],[
- AC_MSG_RESULT(static)
- AC_MSG_ERROR([gmp.h isn't a DLL: use --enable-static --disable-shared]) ])
- else
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "gmp.h"
-#if __GMP_LIBGMP_DLL
-# error "Dead man"
-error
-#endif
- ]], [[]])],[AC_MSG_RESULT(static)],[
- AC_MSG_RESULT(DLL)
- AC_MSG_ERROR([gmp.h is a DLL: use --disable-static --enable-shared]) ])
- fi
- ;;
-esac
-dnl Finally set up LibTool
-AC_PROG_LIBTOOL
-
-# Checks for libraries.
-AC_CHECK_LIB([gmp], [__gmpz_init],
- [LIBS="-lgmp $LIBS"],
- [AC_MSG_ERROR([libgmp not found or uses a different ABI.])])
-AC_MSG_CHECKING(for MPFR)
-LIBS="-lmpfr $LIBS"
-AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include "mpfr.h"]],
- [[mpfr_t x; mpfr_init(x) ; mpfr_clear(x);]]
- )],
- [AC_MSG_RESULT(yes)],
- [
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([libmpfr not found or uses a different ABI.])
- ])
-
-# Check for a recent GMP
-AC_MSG_CHECKING(for recent GMP)
-AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE(
- [[
-#include "gmp.h"
-#if (__GNU_MP_VERSION*100 + __GNU_MP_VERSION_MINOR*10 < 420)
-# error "min GMP version is 4.2"
-error
-#endif
- ]])],
- [AC_MSG_RESULT(yes)],
- [
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([GMP version >= 4.2 required])
- ])
-
-# Check for a recent MPFR
-AC_MSG_CHECKING(for recent MPFR)
-AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE(
- [[
-#include "mpfr.h"
-#if (MPFR_VERSION < MPFR_VERSION_NUM (2,3,1))
-# error "min MPFR version is 2.3.1"
-error
-#endif
- ]])],
- [AC_MSG_RESULT(yes)],
- [
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([MPFR version >= 2.3.1 required])
- ])
-
-# Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS([locale.h inttypes.h limits.h unistd.h sys/time.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_TYPE_SIZE_T
-AC_HEADER_TIME
-
-# Checks for library functions.
-AC_CHECK_FUNCS([gettimeofday])
-AC_CHECK_FUNCS([dup dup2 fileno],,
- [AC_DEFINE([NO_STREAM_REDIRECTION],1,[Do not check mpc_out_str on stdout])])
-
-# Checks if compiler accepts warning flags.
-case $host in
- *-*-cygwin* | *-*-mingw*) ;;
- *) AX_C_CHECK_FLAG(-ansi,,,WARNINGCFLAGS="$WARNINGCFLAGS -ansi",) ;;
-esac
-AX_C_CHECK_FLAG(-pedantic,,,WARNINGCFLAGS="$WARNINGCFLAGS -pedantic",)
-AX_C_CHECK_FLAG(-Wall,,,WARNINGCFLAGS="$WARNINGCFLAGS -Wall",)
-AX_C_CHECK_FLAG(-Wextra,,,WARNINGCFLAGS="$WARNINGCFLAGS -Wextra",)
-AX_C_CHECK_FLAG(-Werror,,,WARNINGCFLAGS="$WARNINGCFLAGS -Werror",)
-AC_SUBST(WARNINGCFLAGS)
-
-AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile doc/Makefile])
-AC_OUTPUT
+/* configure.ac
+
+Copyright (C) 2008, 2009 Andreas Enge, Philippe Th\'eveny
+
+This file is part of the MPC Library.
+
+The MPC Library is free software; you can redistribute it and/or modify
+it under the terms of the GNU Lesser General Public License as published by
+the Free Software Foundation; either version 2.1 of the License, or (at your
+option) any later version.
+
+The MPC Library is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public
+License for more details.
+
+You should have received a copy of the GNU Lesser General Public License
+along with the MPC Library; see the file COPYING.LIB. If not, write to
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
+MA 02111-1307, USA. */
+
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT(mpc, 0.6-dev, mpc-discuss@lists.gforge.inria.fr)
+AC_CONFIG_SRCDIR([src/mpc-impl.h])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE([1.9 -Wall -Werror])
+AM_MAINTAINER_MODE
+
+dnl Extra arguments to configure
+AC_ARG_WITH([mpfr_include],
+ [AC_HELP_STRING([--with-mpfr-include=DIR],
+ [MPFR include directory])],
+ [CPPFLAGS="-I$withval $CPPFLAGS"])
+AC_ARG_WITH([mpfr_lib],
+ [AC_HELP_STRING([--with-mpfr-lib=DIR],
+ [MPFR lib directory])],
+ [LDFLAGS="-L$withval $LDFLAGS"])
+AC_ARG_WITH([mpfr],
+ [AC_HELP_STRING([--with-mpfr=DIR],
+ [MPFR install directory])],
+ [
+ CPPFLAGS="-I$withval/include $CPPFLAGS"
+ LDFLAGS="-L$withval/lib $LDFLAGS"
+ ])
+AC_ARG_WITH([gmp_include],
+ [AC_HELP_STRING([--with-gmp-include=DIR],
+ [GMP include directory])],
+ [CPPFLAGS="-I$withval $CPPFLAGS"])
+AC_ARG_WITH([gmp_lib],
+ [AC_HELP_STRING([--with-gmp-lib=DIR],
+ [GMP lib directory])],
+ [LDFLAGS="-L$withval $LDFLAGS"])
+AC_ARG_WITH([gmp],
+ [AC_HELP_STRING([--with-gmp=DIR],
+ [GMP install directory])],
+ [
+ CPPFLAGS="-I$withval/include $CPPFLAGS"
+ LDFLAGS="-L$withval/lib $LDFLAGS"
+ ])
+AC_ARG_VAR([MPC_USE_LOGGING], [defined if logging support wanted])
+AC_ARG_ENABLE([logging],
+ [AC_HELP_STRING([--enable-logging],
+ [enable MPC logging [default=no]])],
+ [
+ case $enableval in
+ yes) AC_DEFINE([MPC_USE_LOGGING],1,[Logging support]) ;;
+ no) ;;
+ *) AC_MSG_ERROR([bad value for --enable-logging: yes or no])
+ ;;
+ esac
+ ])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_SED
+case $host in
+ *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
+ AC_MSG_CHECKING(for DLL/static GMP)
+ if test "$enable_shared" = yes; then
+ LDFLAGS="$LDFLAGS -no-undefined"
+ dont_link_with_gmp="yes"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include "gmp.h"
+#if !__GMP_LIBGMP_DLL
+# error "Dead man"
+error
+#endif
+ ]], [[]])],[AC_MSG_RESULT(DLL)],[
+ AC_MSG_RESULT(static)
+ AC_MSG_ERROR([gmp.h isn't a DLL: use --enable-static --disable-shared]) ])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include "mpfr.h"
+#if !__GMP_LIBGMP_DLL
+# error "Dead man"
+error
+#endif
+ ]], [[]])],[AC_MSG_RESULT(DLL)],[
+ AC_MSG_RESULT(static)
+ AC_MSG_ERROR([gmp.h isn't a DLL: use --enable-static --disable-shared]) ])
+ else
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include "gmp.h"
+#if __GMP_LIBGMP_DLL
+# error "Dead man"
+error
+#endif
+ ]], [[]])],[AC_MSG_RESULT(static)],[
+ AC_MSG_RESULT(DLL)
+ AC_MSG_ERROR([gmp.h is a DLL: use --disable-static --enable-shared]) ])
+ fi
+ ;;
+esac
+dnl Finally set up LibTool
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+AC_CHECK_LIB([gmp], [__gmpz_init],
+ [LIBS="-lgmp $LIBS"],
+ [AC_MSG_ERROR([libgmp not found or uses a different ABI.])])
+AC_MSG_CHECKING(for MPFR)
+LIBS="-lmpfr $LIBS"
+AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include "mpfr.h"]],
+ [[mpfr_t x; mpfr_init(x) ; mpfr_clear(x);]]
+ )],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([libmpfr not found or uses a different ABI.])
+ ])
+
+# Check for a recent GMP
+AC_MSG_CHECKING(for recent GMP)
+AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE(
+ [[
+#include "gmp.h"
+#if (__GNU_MP_VERSION*100 + __GNU_MP_VERSION_MINOR*10 < 420)
+# error "min GMP version is 4.2"
+error
+#endif
+ ]])],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([GMP version >= 4.2 required])
+ ])
+
+# Check for a recent MPFR
+AC_MSG_CHECKING(for recent MPFR)
+AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE(
+ [[
+#include "mpfr.h"
+#if (MPFR_VERSION < MPFR_VERSION_NUM (2,3,1))
+# error "min MPFR version is 2.3.1"
+error
+#endif
+ ]])],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([MPFR version >= 2.3.1 required])
+ ])
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([locale.h inttypes.h limits.h unistd.h sys/time.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_CHECK_FUNCS([gettimeofday])
+AC_CHECK_FUNCS([dup dup2 fileno],,
+ [AC_DEFINE([NO_STREAM_REDIRECTION],1,[Do not check mpc_out_str on stdout])])
+
+# Checks if compiler accepts warning flags.
+case $host in
+ *-*-cygwin* | *-*-mingw*) ;;
+ *) AX_C_CHECK_FLAG(-ansi,,,WARNINGCFLAGS="$WARNINGCFLAGS -ansi",) ;;
+esac
+AX_C_CHECK_FLAG(-pedantic,,,WARNINGCFLAGS="$WARNINGCFLAGS -pedantic",)
+AX_C_CHECK_FLAG(-Wall,,,WARNINGCFLAGS="$WARNINGCFLAGS -Wall",)
+AX_C_CHECK_FLAG(-Wextra,,,WARNINGCFLAGS="$WARNINGCFLAGS -Wextra",)
+AX_C_CHECK_FLAG(-Werror,,,WARNINGCFLAGS="$WARNINGCFLAGS -Werror",)
+AC_SUBST(WARNINGCFLAGS)
+
+AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile doc/Makefile])
+AC_OUTPUT