summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-07-21 16:51:03 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-07-21 16:51:03 +0000
commitbf328ef176489ce913a7206ff64b18046d5230da (patch)
tree045c59892956a2d8be0cafdbe909704983a25062 /configure.ac
parentdb5f5b06ff7776c8e9d7089c82487894f4ef3c2b (diff)
downloadmpc-bf328ef176489ce913a7206ff64b18046d5230da.tar.gz
configure.ac, mpc.m4: under windows, check first for mpfr, then for dlls
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@1016 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 893f176..a5cb05c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,13 +112,6 @@ if test -z "$user_redefine_cc" ; then
fi
-# Configs for Windows DLLs
-case $host in
- *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
- MPC_WINDOWS
-esac
-
-
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([locale.h inttypes.h stdint.h limits.h unistd.h sys/time.h])
@@ -197,6 +190,14 @@ AS_IF([test "x$enable_logging" = "xyes"],
]
)
+
+# Configs for Windows DLLs
+case $host in
+ *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
+ MPC_WINDOWS
+esac
+
+
# Checks if compiler accepts warning flags.
MPC_PROG_CC_WARNINGCFLAGS([WARNINGCFLAGS])