summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2010-05-24 08:34:05 +0000
committerzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2010-05-24 08:34:05 +0000
commite192efd130ffd535d02607e7245a80b410100f98 (patch)
treea29709d2ad00eb9887df7f390459a84b382aaba7 /configure.ac
parent05566ec6553b55dff101d70627c24465f5603776 (diff)
downloadmpc-e192efd130ffd535d02607e7245a80b410100f98.tar.gz
[configure.ac] added check for gmp.h before checking for DLLs
(should solve the misleading error message on mingw) git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@774 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9080c12..ac35927 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,6 +87,15 @@ AC_PROG_EGREP
AC_PROG_SED
AC_LANG(C)
+dnl Check GMP Header
+AC_MSG_CHECKING(for gmp.h)
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+#include "gmp.h"
+]])],[AC_MSG_RESULT(yes)],[
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([gmp.h can't be found, or is unusable.])
+])
+
dnl Check for GMP CFLAGS in gmp.h
if test -z "$user_redefine_cc" ; then
MPC_GMP_CC_CFLAGS