summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-19 13:24:40 +0000
committerthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-03-19 13:24:40 +0000
commitef740b68bd5fe98a9467743b8487b28571d9c418 (patch)
tree1d048af0b174f1416a59be9eb5802596eefb46c3 /configure.ac
parent8f1b5c22eff74d6d474f874961b8b278c0aed2cd (diff)
downloadmpc-ef740b68bd5fe98a9467743b8487b28571d9c418.tar.gz
configure.ac: prevent use of --with-gmp and --with-gmp-lib/--with-gmp-include simultaneously (m.m. --with-mpfr).
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@476 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0e85f06..84fffe1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,8 +45,12 @@ AC_ARG_WITH([mpfr],
[AC_HELP_STRING([--with-mpfr=DIR],
[MPFR install directory])],
[
- CPPFLAGS="-I$withval/include $CPPFLAGS"
- LDFLAGS="-L$withval/lib $LDFLAGS"
+ if test -z "$with_mpfr_include" -a -z "$with_mpfr_lib" ; then
+ CPPFLAGS="-I$withval/include $CPPFLAGS"
+ LDFLAGS="-L$withval/lib $LDFLAGS"
+ else
+ AC_MSG_FAILURE([Do not use --with-mpfr and --with-mpfr-include/--with-mpfr-lib options simultaneously.])
+ fi
])
AC_ARG_WITH([gmp_include],
[AC_HELP_STRING([--with-gmp-include=DIR],
@@ -60,8 +64,12 @@ AC_ARG_WITH([gmp],
[AC_HELP_STRING([--with-gmp=DIR],
[GMP install directory])],
[
- CPPFLAGS="-I$withval/include $CPPFLAGS"
- LDFLAGS="-L$withval/lib $LDFLAGS"
+ if test -z "$with_gmp_lib" -a -z "$with_gmp_include" ; then
+ CPPFLAGS="-I$withval/include $CPPFLAGS"
+ LDFLAGS="-L$withval/lib $LDFLAGS"
+ else
+ AC_MSG_FAILURE([Do not use --with-gmp and --with-gmp-include/--with-gmp-lib options simultaneously.])
+ fi
])
AC_ARG_VAR([MPC_USE_LOGGING], [defined if logging support wanted])
AC_ARG_ENABLE([logging],