summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-02-18 14:38:08 +0000
committerthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-02-18 14:38:08 +0000
commitea472cfe91dcb532342adce4ef74074f9c8eccaa (patch)
treef3538b459f789fd78e114dc55d8df43d957dfcb3 /src/Makefile.am
parent9c305dd081f8e646d5ad37037992e8b5e1569eef (diff)
downloadmpc-ea472cfe91dcb532342adce4ef74074f9c8eccaa.tar.gz
doc/mpc.texi: Add documentation for new functions mpc_set_str and mpc_strtoc.
doc/version.texi: Update to february 2009. NEWS src/mpc.h src/Makefile.am: Add new functions mpc_set_str and mpc_strtoc. configure.ac: Check if locale.h exists. src/strtoc.c: new function. src/set_str.c: new function. tests/mpc-tests.h: make public some helper functions from read_data.c. tests/read_data.c: make public some helper functions. tests/Makefile.am: Add tstrtoc.c and tstrtoc.dat. tests/tstrtoc.c: test file for mpc_strtoc. tests/strtoc.dat: data file for mpc_strtoc. git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@414 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 41784c6..02a105c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,5 +8,5 @@ cmp.c cmp_si_si.c conj.c cos.c cosh.c div_2exp.c div.c div_fr.c div_ui.c exp.c \
fr_div.c fr_sub.c get_prec2.c get_prec.c get_version.c imag.c init2.c init3.c \
inp_str.c log.c mul_2exp.c mul.c mul_fr.c mul_i.c mul_si.c mul_ui.c neg.c \
norm.c out_str.c proj.c random2.c random.c real.c urandom.c set.c set_prec.c \
-set_x.c set_x_x.c sin.c sinh.c sqr.c sqrt.c sub.c sub_fr.c sub_ui.c tan.c \
-tanh.c uceil_log2.c ui_div.c ui_ui_sub.c
+set_str.c set_x.c set_x_x.c sin.c sinh.c sqr.c sqrt.c strtoc.c sub.c sub_fr.c \
+sub_ui.c tan.c tanh.c uceil_log2.c ui_div.c ui_ui_sub.c