summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2010-05-15 12:03:16 +0000
committerzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2010-05-15 12:03:16 +0000
commit1a1bea2d276bc0f8c517feb153ca09389d68fa81 (patch)
tree32263fe068865c88229aaa69bc8c0dff0cf812a1 /tests/Makefile.am
parent6da61c7fe250b2a1770cd536653510a666e3af2e (diff)
downloadmpc-1a1bea2d276bc0f8c517feb153ca09389d68fa81.tar.gz
[tests/Makefile.am] fixed LOADLIBES so that "make foo" works again
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@768 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ccf8f8..828f6b9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,10 @@
AM_CFLAGS=@WARNINGCFLAGS@
AM_CPPFLAGS = -I$(top_srcdir)/src
LDADD = libmpc-tests.la $(top_builddir)/src/libmpc.la
-LOADLIBES=$(DEFS) -I$(top_srcdir)/src $(CPPFLAGS) $(CFLAGS) $(top_builddir)/src/.libs/libmpc.a $(LIBS)
+# LOADLIBES (documented in the "GNU make" manual and equivalent to LDLIBS)
+# enables to compile a program foo.c in the test directory by simply doing
+# "make foo".
+LOADLIBES=$(DEFS) -I$(top_srcdir)/src -I$(top_builddir) $(CPPFLAGS) $(CFLAGS) $(top_builddir)/tests/.libs/libmpc-tests.a $(top_builddir)/src/.libs/libmpc.a $(LIBS)
check_PROGRAMS = tabs tacos tacosh tadd tadd_fr tadd_ui targ tasin tasinh \
tatan tatanh tconj tcos tcosh tdiv tdiv_2exp tdiv_fr tdiv_ui texp tfr_div \