summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-06-04 15:01:27 +0000
committerzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2009-06-04 15:01:27 +0000
commit6a4e5870c8208c675022e983709dba0f66139e4e (patch)
tree0cd15baa966bd357704e7bf15a80c803137465c7 /tests/Makefile.am
parent4c8c5c423597002a6d2367d132cb3c7b1a1ae00a (diff)
downloadmpc-6a4e5870c8208c675022e983709dba0f66139e4e.tar.gz
First version of mpc_pow. Seems to run ok, but we have problems with large
exponents, since it is doubly-exponential wrt the maximal exponent! I let Philippe fill the special cases, and add some more tests in pow.dat. The algorithm is documented both in algorithms.tex and in the source code. git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@552 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5d88ad5..653b346 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,8 +5,8 @@ LDADD = libmpc-tests.la $(top_builddir)/src/libmpc.la
check_PROGRAMS = tabs tadd tadd_fr tadd_ui targ tconj tcos tcosh tdiv \
tdiv_2exp tdiv_fr tdiv_ui texp tfr_div tfr_sub tget_version timag tio_str \
-tlog tmul tmul_2exp tmul_fr tmul_i tmul_si tmul_ui tneg tnorm tprec tproj \
-treal treimref tset tsin tsinh tsqr tsqrt tstrtoc tsub tsub_fr tsub_ui \
+tlog tmul tmul_2exp tmul_fr tmul_i tmul_si tmul_ui tneg tnorm tpow tprec \
+tproj treal treimref tset tsin tsinh tsqr tsqrt tstrtoc tsub tsub_fr tsub_ui \
ttan ttanh tui_div tui_ui_sub
check_LTLIBRARIES=libmpc-tests.la
@@ -15,8 +15,8 @@ comparisons.c
EXTRA_DIST = abs.dat add.dat add_fr.dat arg.dat conj.dat cos.dat cosh.dat \
div.dat div_fr.dat exp.dat fr_div.dat fr_sub.dat inp_str.dat log.dat mul.dat \
-mul_fr.dat neg.dat norm.dat proj.dat sin.dat sinh.dat sqr.dat sqrt.dat \
-strtoc.dat sub.dat sub_fr.dat tan.dat tanh.dat
+mul_fr.dat neg.dat norm.dat pow.dat proj.dat sin.dat sinh.dat sqr.dat \
+sqrt.dat strtoc.dat sub.dat sub_fr.dat tan.dat tanh.dat
TESTS = $(check_PROGRAMS)
CLEANFILES = mpc_test