summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 23 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3e3800a..9a351a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,19 +2,38 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT(mpc, 0.4.6, mpc@loria.fr)
-AC_CONFIG_SRCDIR([set_d_d.c])
+AC_INIT(mpc, 0.4.7, mpc-discuss@lists.gforge.inria.fr)
+AC_CONFIG_SRCDIR([mpc-impl.h])
AC_CONFIG_HEADER([config.h])
-AM_INIT_AUTOMAKE([1.9 foreign])
+AM_INIT_AUTOMAKE([1.9 -Wall -Werror])
AM_MAINTAINER_MODE
+AM_CFLAGS="-O2 -g"
+
+dnl Extra arguments to configure
+AC_ARG_WITH([mpfr],
+ AC_HELP_STRING([--with-mpfr=DIR],
+ [MPFR install directory]),
+ [
+ CPPFLAGS="$CPPFLAGS -I$withval/include"
+ LDFLAGS="$LDFLAGS -L$withval/lib"
+ ])
+AC_ARG_WITH([gmp],
+ AC_HELP_STRING([--with-gmp=DIR],
+ [GMP install directory]),
+ [
+ CPPFLAGS="$CPPFLAGS -I$withval/include"
+ LDFLAGS="$LDFLAGS -L$withval/lib"
+ ])
+
# Checks for programs.
AC_PROG_CC
AC_PROG_LIBTOOL
# Checks for libraries.
-AC_CHECK_LIB([mpfr], [mpfr_clear])
+AC_CHECK_LIB([mpfr], [mpfr_clear],,
+ AC_MSG_ERROR([MPC library needs the MPFR library]))
# Checks for header files.
AC_HEADER_STDC