summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4da274..31b45cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,16 @@ AC_ARG_ENABLE([logging],
esac
]
)
-
+AC_ARG_ENABLE([valgrind],
+ [AC_HELP_STRING([--enable-valgrind],
+ [enable valgrind for make check (default = no)])],
+ [case $enableval in
+ yes) AC_CHECK_PROG([VALGRIND], [valgrind], [valgrind -q --error-exitcode=1]) ;;
+ no) ;;
+ *) AC_MSG_ERROR([Bad value for --enable-valgrind: Use yes or no]) ;;
+ esac
+ ]
+ )
# Setup CC and CFLAGS
AC_PROG_CC
@@ -202,7 +211,6 @@ AS_IF([test "x$enable_logging" = "xyes"],
]
)
-
# Configs for Windows DLLs
case $host in
*-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)