summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorschevill <schevill@280ebfd0-de03-0410-8827-d642c229c3f4>2010-05-18 14:34:57 +0000
committerschevill <schevill@280ebfd0-de03-0410-8827-d642c229c3f4>2010-05-18 14:34:57 +0000
commit0d511f8adaa7babd685ea7d3ee6b99a2c6bc6283 (patch)
tree1a61fba64179dffe3da52390711be89b87bb0f7c /Makefile.am
parent13549c0f3c696341e3826cdf34a9cd858a41ceaf (diff)
downloadmpfr-0d511f8adaa7babd685ea7d3ee6b99a2c6bc6283.tar.gz
* I added a new implementation of Airy Ai. This implementation uses Smith's
algorithm. Currently, it is provided as a separate implementation mpfr_ai2. * Please note that both mpfr_ai and mpfr_ai2 need to efficiently evaluate Gamma(1/3) and Gamma(2/3). This is provided by functions in the file gammaonethird.c * There is no test file for mpfr_ai2 since it should quickly disappear behind a single implementation using the best of mpfr_ai and mpfr_ai2. However, if necessary, a test file can be obtained by copying tai.c and replacing mpfr_ai by mpfr_ai2 everywhere. * I do not know if gammaonethird.c will remain like that in the future. Should we make this implementation available as a public MPFR function? In this case, I have to write a wrapper for providing a correctly rounded implementation. Moreover, it contains functions that could be interesting for the implementation of other functions (the functions mpfr_div_ui*). Maybe, it could be worth providing a file specially for this purpose. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6804 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c85ae7cc6..dc8440bee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,7 +55,7 @@ round_near_x.c constant.c abort_prec_max.c stack_interface.c lngamma.c \
zeta_ui.c set_d64.c get_d64.c jn.c yn.c rem1.c get_patches.c add_d.c \
sub_d.c d_sub.c mul_d.c div_d.c d_div.c li2.c rec_sqrt.c min_prec.c \
buildopt.c digamma.c bernoulli.c isregular.c set_flt.c get_flt.c \
-scale2.c set_z_exp.c ai.c
+scale2.c set_z_exp.c ai.c ai2.c gammaonethird.c
libmpfr_la_LIBADD = @LIBOBJS@