summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-01-30 09:49:35 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-01-30 09:49:35 +0000
commit780cc04376c6736056103589cd21c89d74fef01a (patch)
treec68388e530d7c45d1b30d169efb218fd4c5dd6f5 /configure.ac
parentab2279a252b70a62d3a9a26498df4799838f646f (diff)
downloadmpfr-780cc04376c6736056103589cd21c89d74fef01a.tar.gz
[configure.ac] Updated comment about default options in CFLAGS for GCC.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13423 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2fdb7626b..951d00ac6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -477,8 +477,13 @@ error
CFLAGS="-fp_port -mieee-fp -wd1572 -wd265 -wd186 -wd239 $CFLAGS"
],[AC_MSG_RESULT(no)])
-dnl If compiler is gcc, then use some specific flags.
-dnl But don't touch user other flags.
+dnl If CFLAGS has not been set explicitly and the compiler is GCC, then
+dnl use some specific flags. But don't touch user other flags.
+dnl Note: This is done even when CFLAGS has been set from GMP's CFLAGS
+dnl (__GMP_CFLAGS macro in gmp.h) above. The consequence is that this
+dnl might yield a compilation failure if the -Werror option appears in
+dnl __GMP_CFLAGS. But in this case, since -Werror is not used by default,
+dnl one may expect that the user would also set CFLAGS for MPFR.
if test "$test_CFLAGS" != set && test -n "$GCC"; then
CFLAGS="-Wpointer-arith $CFLAGS"
AC_MSG_CHECKING(whether the selected language is C++)