summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-06-13 13:17:53 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-06-13 13:17:53 +0000
commitbb8ca81b0389208e835dbdb4defa40d9405d2e06 (patch)
treedc124c296aa91cfe1583c226657a3bad25fb8dc8 /configure.ac
parent6c70b4e6ada9c8b9e5a8cae6b1878cb873093b35 (diff)
downloadmpfr-bb8ca81b0389208e835dbdb4defa40d9405d2e06.tar.gz
[configure.ac] No longer add -Wc++-compat to CFLAGS when the compiler
is GCC not in C++ mode (reverting the change done in r13406) since this option is not available before GCC 4.1: https://sympa.inria.fr/sympa/arc/mpfr/2020-06/msg00008.html git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@14018 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1054adc0e..38d59c65e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -458,6 +458,8 @@ dnl (__GMP_CFLAGS macro in gmp.h) above. The consequence is that this
dnl might yield a compilation failure if the -Werror option appears in
dnl __GMP_CFLAGS. But in this case, since -Werror is not used by default,
dnl one may expect that the user would also set CFLAGS for MPFR.
+dnl Note: When the compiler is GCC not in C++ mode, -Wc++-compat may be
+dnl interesting, but it has been introduced in GCC 4.1 only.
if test "$test_CFLAGS" != set && test -n "$GCC"; then
CFLAGS="-Wpointer-arith $CFLAGS"
AC_MSG_CHECKING(whether the selected language is C++)
@@ -468,7 +470,7 @@ error
#endif
]], [[]])],[
AC_MSG_RESULT(no)
- CFLAGS="-Wmissing-prototypes -Wc++-compat $CFLAGS"
+ CFLAGS="-Wmissing-prototypes $CFLAGS"
],[
AC_MSG_RESULT(yes)
CFLAGS="-Wmissing-declarations -Wno-sign-compare $CFLAGS"