summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2002-04-02 23:42:48 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2002-04-02 23:42:48 +0000
commit7fcc5b7096f4a3ea39d9280df903f27418306f8c (patch)
tree093da4726563072412c95e0b520a2a898262abdf /configure.in
parent2fd8f1790dd0d7d21e41eef9c890cc6258da6967 (diff)
downloadmpfr-7fcc5b7096f4a3ea39d9280df903f27418306f8c.tar.gz
[ ] used around error message.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@1800 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f06b6de81..d9c0a6cd6 100644
--- a/configure.in
+++ b/configure.in
@@ -70,7 +70,8 @@ AC_TRY_COMPILE([
#include "longlong.h"
], , AC_MSG_RESULT(yes),
[AC_MSG_RESULT(no)
- AC_MSG_ERROR(gmp.h or gmp-impl.h or config.h or gmp-mparam.h or longlong.h may be missing ${with_gmp_include:+in $with_gmp_include})]
+ AC_MSG_ERROR([gmp.h or gmp-impl.h or config.h or gmp-mparam.h or
+longlong.h may be missing ${with_gmp_include:+in $with_gmp_include}])]
)
dnl Check BITS_PER_MP_LIMB and BYTES_PER_MP_LIMB
@@ -86,12 +87,11 @@ int main()
}
], AC_MSG_RESULT(yes),
[AC_MSG_RESULT(no)
-dnl do not use the AC_MSG_ERROR macro because of message truncation...
-{ echo "configure: error: BITS_PER_MP_LIMB and/or BYTES_PER_MP_LIMB are incorrect.
+ AC_MSG_ERROR([BITS_PER_MP_LIMB and/or BYTES_PER_MP_LIMB are incorrect.
You probably need to change some of the GMP or MPFR compile options:
MPFR doesn't currently do as many architecture checks as GMP, so the
-default target architecture may be different, hence the error." 1>&2
- exit 1; }])
+default target architecture may be different, hence the error.])]
+)
dnl Check random functions
AC_MSG_CHECKING(for rand48 functions)