summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2009-11-24 15:44:44 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2009-11-24 15:44:44 +0000
commitcb888bf915565e30510b189ef10cfaa6425c0c7c (patch)
treed12c17a81eaea33820d6e3e73283587fed52d2bc /configure.in
parent2e144150ed5c45e64a4dfbf894a1a4abf73eb256 (diff)
downloadmpfr-cb888bf915565e30510b189ef10cfaa6425c0c7c.tar.gz
configure.in: replaced "test ... -a ..." (obsolete in POSIX)
by "test ... && test ...". git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6566 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 30c4caccc..162d42b0f 100644
--- a/configure.in
+++ b/configure.in
@@ -60,7 +60,7 @@ AC_ARG_WITH(gmp_lib,
])
AC_ARG_WITH(gmp,
[ --with-gmp=DIR GMP install directory ], [
- if test -z "$with_gmp_lib" -a -z "$with_gmp_include" ; then
+ if test -z "$with_gmp_lib" && test -z "$with_gmp_include" ; then
CPPFLAGS="$CPPFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
gmp_lib_path="$withval/lib"
@@ -72,7 +72,7 @@ AC_ARG_WITH(gmp,
AC_ARG_WITH(gmp_build,
[ --with-gmp-build=DIR GMP build directory (please read INSTALL file)],
[
- if test -z "$gmp_lib_path" -a -z "$with_gmp_include" ; then
+ if test -z "$gmp_lib_path" && test -z "$with_gmp_include" ; then
CPPFLAGS="$CPPFLAGS -I$withval -I$withval/tune"
LDFLAGS="$LDFLAGS -L$withval -L$withval/.libs -L$withval/tune/"
gmp_lib_path="$withval$PATH_SEPARATOR$withval/.libs$PATH_SEPARATOR$withval/tune"
@@ -152,7 +152,7 @@ AC_PROG_SED
AC_LANG(C)
dnl Check for GMP CFLAGS in gmp.h
-if test -z "$GMP_CFLAGS" -a -z "$user_redefine_cc" ; then
+if test -z "$GMP_CFLAGS" && test -z "$user_redefine_cc" ; then
AC_MSG_CHECKING(for CC and CFLAGS in gmp.h)
# FIXME: Move this in aclocal ?
# Get CC