summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorthevenyp <thevenyp@280ebfd0-de03-0410-8827-d642c229c3f4>2009-01-19 11:05:10 +0000
committerthevenyp <thevenyp@280ebfd0-de03-0410-8827-d642c229c3f4>2009-01-19 11:05:10 +0000
commitf77f16b313adf487eeb68503782135a2b5724f99 (patch)
tree07688c3c9a2bdf8c3319ec4c7cde39c5f2e6c5c0 /configure.in
parentdc6d8c36cbe71a48fbd62cf810ae4ad644750727 (diff)
downloadmpfr-f77f16b313adf487eeb68503782135a2b5724f99.tar.gz
INSTALL: Warn that --with-gmp, --with-gmp-include/--with-gmp-lib, and --with-gmp-build options are mutually exclusive.
configure.in: Check and fail if --with-gmp, --with-gmp-include/--with-gmp-lib, or --with-gmp-build are use simultaneously. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@5834 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 19 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 6a907441f..7621f867b 100644
--- a/configure.in
+++ b/configure.in
@@ -54,22 +54,30 @@ AC_ARG_WITH(gmp_lib,
])
AC_ARG_WITH(gmp,
[ --with-gmp=DIR GMP install directory ], [
- CPPFLAGS="$CPPFLAGS -I$withval/include"
- LDFLAGS="$LDFLAGS -L$withval/lib"
- gmp_lib_path="$withval/lib"
+ if test -z "$with_gmp_lib" -a -z "$with_gmp_include" ; then
+ CPPFLAGS="$CPPFLAGS -I$withval/include"
+ LDFLAGS="$LDFLAGS -L$withval/lib"
+ gmp_lib_path="$withval/lib"
+ else
+ AC_MSG_FAILURE([Do not use --with-gmp and --with-gmp-include/--with-gmp-lib options simultaneously.])
+ fi
])
AC_ARG_WITH(gmp_build,
[ --with-gmp-build=DIR GMP build directory (please read INSTALL file)],
[
- CPPFLAGS="$CPPFLAGS -I$withval -I$withval/tune"
- LDFLAGS="$LDFLAGS -L$withval -L$withval/.libs -L$withval/tune/"
- gmp_lib_path="$withval$PATH_SEPARATOR$withval/.libs$PATH_SEPARATOR$withval/tune"
- if test -r $withval/Makefile ; then
- GMP_CFLAGS=`grep -w "CFLAGS =" $withval/Makefile | sed 's/CFLAGS = //'`
- GMP_CC=`grep -w "CC =" $withval/Makefile | sed 's/CC = //'`
- fi
- use_gmp_build=yes
+ if test -z "$gmp_lib_path" -a -z "$with_gmp_include" ; then
+ CPPFLAGS="$CPPFLAGS -I$withval -I$withval/tune"
+ LDFLAGS="$LDFLAGS -L$withval -L$withval/.libs -L$withval/tune/"
+ gmp_lib_path="$withval$PATH_SEPARATOR$withval/.libs$PATH_SEPARATOR$withval/tune"
+ if test -r $withval/Makefile ; then
+ GMP_CFLAGS=`grep -w "CFLAGS =" $withval/Makefile | sed 's/CFLAGS = //'`
+ GMP_CC=`grep -w "CC =" $withval/Makefile | sed 's/CC = //'`
+ fi
+ use_gmp_build=yes
+ else
+ AC_MSG_FAILURE([Do not use --with-gmp-build and other --with-gmp options simultaneously.])
+ fi
])
AC_ARG_WITH(mulhigh_size,