summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..211f1c5
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([Multitouch Protocol Translation Library],
+ [1.1.3],
+ [],
+ [mtdev])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([config-aux])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+LIB_VERSION=1:0:0
+AC_SUBST([LIB_VERSION])
+
+# Initialize libtool
+AC_PROG_LIBTOOL
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile
+ test/Makefile
+ mtdev.pc])
+AC_OUTPUT