summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..16d388c
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,27 @@
+lib_LTLIBRARIES = libmtdev.la
+
+libmtdev_la_LDFLAGS = -version-info @LIB_VERSION@
+
+libmtdev_la_SOURCES = \
+ $(top_srcdir)/include/mtdev-mapping.h \
+ $(top_srcdir)/include/mtdev-plumbing.h \
+ common.h \
+ evbuf.h \
+ iobuf.h \
+ match.h \
+ state.h \
+ caps.c \
+ core.c \
+ iobuf.c \
+ match.c \
+ match_four.c
+
+AM_CFLAGS = $(CWARNFLAGS) #-DMTDEV_NO_LEGACY_ABI
+
+INCLUDES = -I$(top_srcdir)/include/
+
+libmtdevincludedir = $(includedir)
+libmtdevinclude_HEADERS = \
+ $(top_srcdir)/include/mtdev-mapping.h \
+ $(top_srcdir)/include/mtdev-plumbing.h \
+ $(top_srcdir)/include/mtdev.h