summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGarrett D'Amore <garrett@damore.org>2016-04-25 11:17:00 -0700
committerGarrett D'Amore <garrett@damore.org>2016-04-25 11:17:00 -0700
commit3d527e88a015541f5694714d277ba37321d57e86 (patch)
tree22530bf306a29b28911503b259c3271a9cd2d0d3 /CMakeLists.txt
parentb5224d57d46414d789045a6c0e5dc2bb7da11351 (diff)
downloadnanomsg-3d527e88a015541f5694714d277ba37321d57e86.tar.gz
fixes #668 Enable cmake policy CMP0042
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 788bc73..a16976a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,11 @@ include (CheckLibraryExists)
include (CheckCSourceCompiles)
include (GNUInstallDirs)
+if (POLICY CMP0042)
+ # Newer cmake on MacOS should use @rpath
+ cmake_policy (SET CMP0042 NEW)
+endif ()
+
set (ISSUE_REPORT_MSG "Please consider opening an issue at https://github.com/nanomsg/nanomsg with your findings")
# Determine library versions.