summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2019-02-22 01:13:52 -0800
committerH. Peter Anvin <hpa@zytor.com>2019-02-22 01:18:04 -0800
commit0bddd0f1b14aa614e1dd1c14297527dc24dee29c (patch)
tree890f98ec169ea2ee2a241edd7fdcacc2b7908f21 /configure.ac
parent5a3b4d3802efef94b636d083fe412ab85cdab656 (diff)
downloadnasm-0bddd0f1b14aa614e1dd1c14297527dc24dee29c.tar.gz
autoconf: move aux directory, define AC_CONFIG_AUX_DIR()
The name "aux" is reserved on Windows platforms, a legacy from CP/M via MS-DOS. Rename it to "helpers". Turns out that that directory wasn't actually used properly, because AC_CONFIG_AUX_DIR was never defined, and there was a redundant copy of install-sh checked into the base of the source tree. Reported-by: Ehsan Alem Mohammad Ghasemlou <e.ghasemloo@gmail.com> NASM-Bugzilla: https://bugzilla.nasm.us/show_bug.cgi?id=3392560 Signed-off-by: H. Peter Anvin <hpa@zytor.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e94d8109..83943d62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ dnl a configure script.
AC_PREREQ(2.69)
AC_INIT(config/config.h.in)
AC_CONFIG_HEADERS(config/config.h)
-
AC_PREFIX_PROGRAM(nasm)
+AC_CONFIG_AUX_DIR(autoconf/helpers)
dnl Save initial CFLAGS, to see if -g -O2 came from configure or not
pa_init_cflags="$CFLAGS"