summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin (Intel) <hpa@zytor.com>2019-05-15 13:07:21 -0700
committerH. Peter Anvin (Intel) <hpa@zytor.com>2019-05-15 13:07:21 -0700
commit471120f48504300af5ace45f06980f6c049eb5b5 (patch)
tree939bc1ea865cdd4f417be87b06bc9c858b7db287 /configure.ac
parenta7afe276da2fba43fd906dbaad1497a2e0994693 (diff)
downloadnasm-471120f48504300af5ace45f06980f6c049eb5b5.tar.gz
file.c: handle long pathnames on Windows
Windows supports pathnames up to 32767 UTF-16 characters, but using the standard interfaces only up to 260 characters. Wrap the functions that take filenames on Windows. Clean up the compatiblity layers some more for reduced #ifdefs. Signed-off-by: H. Peter Anvin (Intel) <hpa@zytor.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b92d308c..35116b7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,7 +137,6 @@ AC_CHECK_FUNCS([_fseeki64])
AC_CHECK_FUNCS([ftruncate _chsize _chsize_s])
AC_CHECK_FUNCS([fileno _fileno])
-AC_CHECK_FUNCS(_filelengthi64)
AC_FUNC_MMAP
AC_CHECK_FUNCS(getpagesize)
AC_CHECK_FUNCS(sysconf)
@@ -165,6 +164,7 @@ AC_CHECK_TYPES([struct _stati64])
AC_CHECK_TYPES([struct stat])
AC_CHECK_FUNCS([stat _stati64])
AC_CHECK_FUNCS([fstat _fstati64])
+AC_CHECK_FUNCS([S_ISREG])
dnl Check for functions that might not be declared in the headers for
dnl various idiotic reasons (mostly because of library authors