summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin (Intel) <hpa@zytor.com>2020-06-01 13:10:46 -0700
committerH. Peter Anvin (Intel) <hpa@zytor.com>2020-06-01 13:21:05 -0700
commit5b4de52083512d1676b54666a701c931d04b866a (patch)
treec1bbddf0ea5dd14d0b236440a00edc443843a4d7 /configure.ac
parent5d68f9823e6a4198b8fec73b03c1d0125a2aa6a8 (diff)
downloadnasm-5b4de52083512d1676b54666a701c931d04b866a.tar.gz
BR 3392667: more reasonable limit for expression descent
Set an expression descent limit to 8192, which is more reasonable to expect to work on most platforms. Furthermore, if getrlimit() exists, then try to use it to see if we need to further limit the size. Signed-off-by: H. Peter Anvin (Intel) <hpa@zytor.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 777b364b..85393d03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,7 @@ AC_CHECK_HEADERS(unistd.h)
AC_CHECK_HEADERS(sys/mman.h)
AC_CHECK_HEADERS(sys/types.h)
AC_CHECK_HEADERS(sys/stat.h)
+AC_CHECK_HEADERS(sys/resource.h)
dnl Checks for library functions.
AC_CHECK_FUNCS(strcasecmp stricmp)
@@ -172,6 +173,7 @@ AC_CHECK_FUNCS(mempcpy)
AC_CHECK_FUNCS(getuid)
AC_CHECK_FUNCS(getgid)
+AC_CHECK_FUNCS(getrlimit)
AC_CHECK_FUNCS(realpath)
AC_CHECK_FUNCS(canonicalize_file_name)