summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@linux.intel.com>2018-05-30 11:40:42 -0700
committerH. Peter Anvin <hpa@linux.intel.com>2018-05-30 11:40:42 -0700
commit740ec3572bb4a587a287cdcea201f12fa5f00501 (patch)
treefb7ce904917389d2ddfd8ed7a31c28f7c2490781 /configure.ac
parent1ce81e10effa327362e8cdd316f6ea57c8324ce0 (diff)
downloadnasm-740ec3572bb4a587a287cdcea201f12fa5f00501.tar.gz
malloc: simplify nasm_malloc code, add nasm_strcatn()
Simplify the nasm_malloc() code by moving the pointer check into a common subroutine. We can now issue a filename error even for failures like malloc(). Add support for the gcc sentinel attribute (verify that a list ends with NULL). Add a handful of safe_alloc attributes. Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44c9e179..40a6f62c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,6 +220,7 @@ PA_FUNC_ATTRIBUTE(noreturn)
PA_FUNC_ATTRIBUTE(returns_nonnull)
PA_FUNC_ATTRIBUTE(malloc)
PA_FUNC_ATTRIBUTE(alloc_size, (1))
+PA_FUNC_ATTRIBUTE(sentinel,,, [const char *, ...], ["a","b",NULL])
PA_FUNC_ATTRIBUTE(format, [(printf,1,2)], int, [const char *, ...], ["%d",1])
PA_FUNC_ATTRIBUTE(const)
PA_FUNC_ATTRIBUTE(pure)