summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin (Intel) <hpa@zytor.com>2018-12-13 22:51:22 -0800
committerH. Peter Anvin (Intel) <hpa@zytor.com>2018-12-13 22:51:22 -0800
commit7dc5b2392021e39050187216613b474c51ed5765 (patch)
tree1b2e38f4e91bcee876afeddb55fbcd6c53f7065d /configure.ac
parent7bb13eac112443cbeb27c3f613759e292274c385 (diff)
downloadnasm-7dc5b2392021e39050187216613b474c51ed5765.tar.gz
configure: make section garbage collect the default
Section garbage collect really is quite useful, and it makes managing library source code management a little bit less stressful. It has been used by the official builds for a while now, turn it on by default. Signed-off-by: H. Peter Anvin (Intel) <hpa@zytor.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index dfa74126..09272240 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,12 +231,13 @@ PA_FUNC_ATTRIBUTE_ERROR
dnl
dnl support function sections (if available)
dnl
-PA_ARG_ENABLED([sections],
- [compile with function/data section support],
+PA_ARG_DISABLED([sections],
+ [don't try to compile with function/data section support],
+ [],
[PA_ADD_CLDFLAGS([-ffunction-sections])
PA_ADD_CLDFLAGS([-fdata-sections])
PA_ADD_CLDFLAGS([-Wl,--gc-sections])],
- [])
+ )
dnl
dnl support LTO