summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@linux.intel.com>2018-02-20 12:34:17 -0800
committerH. Peter Anvin <hpa@linux.intel.com>2018-02-20 12:34:17 -0800
commit99d45c850e3962e4c89839dd8531de1c080b3ee7 (patch)
treed86561a75bb0e24cac70ac1c0704cd03ee05dff7 /configure.ac
parent53371ddd17b685f8880c22b8b698e494e0f1059b (diff)
downloadnasm-99d45c850e3962e4c89839dd8531de1c080b3ee7.tar.gz
Fix problem with C99 inlines and -Werror=missing-prototypes
Some older versions of gcc (gcc 4.2.1 at least) produce a warning, promoted to error, on C99 inlines. Do some work to figure out if we need to fall back to GNU inline syntax. Fix some issues with GNU inline syntax. Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1f492103..7f1e1ce6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,6 +287,13 @@ PA_ARG_ENABLED([werror],
)
dnl
+dnl On some versions of gcc, -Werror=missing-prototypes causes problems
+dnl with C99-style external inlines. Test this *after* adding the -Werror
+dnl options.
+dnl
+PA_CHECK_BAD_STDC_INLINE
+
+dnl
dnl support ccache
dnl
PA_ARG_ENABLED([ccache], [compile with ccache], [CC="ccache $CC"], [])