summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@linux.intel.com>2017-11-29 16:04:05 -0800
committerH. Peter Anvin <hpa@linux.intel.com>2017-11-29 16:04:05 -0800
commite5033dfd1c3c30313cf7a428c7bed21c7fae9e5f (patch)
tree817b36021a8fc34a32209c17555db6ed5432d1f2 /configure.ac
parent2dbfdee7808f14805e639e960e2ebe0da17e42f9 (diff)
downloadnasm-e5033dfd1c3c30313cf7a428c7bed21c7fae9e5f.tar.gz
configure.ac: add endian headers to configure test
- Add endian headers to the standard tests if present - Check for __builtin_constant_p() Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8fb98ef8..3c344abd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,7 +99,6 @@ AC_CHECK_HEADERS(stdnoreturn.h)
AC_CHECK_HEADERS(io.h)
AC_CHECK_HEADERS(fcntl.h)
AC_CHECK_HEADERS(unistd.h)
-AC_CHECK_HEADERS(endian.h sys/endian.h machine/endian.h)
AC_CHECK_HEADERS(sys/mman.h)
AC_CHECK_HEADERS(sys/types.h)
AC_CHECK_HEADERS(sys/stat.h)
@@ -176,6 +175,7 @@ AC_SUBST([PDFOPT])
dnl
dnl Look for byte-swapping support...
dnl
+PA_ADD_HEADERS(endian.h sys/endian.h machine/endian.h)
PA_HAVE_FUNC(cpu_to_le16, (0))
PA_HAVE_FUNC(cpu_to_le32, (0))
PA_HAVE_FUNC(cpu_to_le64, (0))
@@ -196,6 +196,11 @@ PA_HAVE_FUNC(_byteswap_ulong, (0))
PA_HAVE_FUNC(_byteswap_uint64, (0))
dnl
+dnl Check for __builtin_constant_p()
+dnl
+PA_HAVE_FUNC(__builtin_constant_p, (0))
+
+dnl
dnl Check for supported gcc attributes; some compilers (e.g. Sun CC)
dnl support these, but don't define __GNUC__ as they don't support
dnl some other features of gcc.