summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin (Intel) <hpa@zytor.com>2018-12-12 14:34:34 -0800
committerH. Peter Anvin (Intel) <hpa@zytor.com>2018-12-12 14:34:34 -0800
commiteb5b3ae0d3383cef2651ae642ad297bc1dc6f228 (patch)
treec16780b9a0ef1bf47009c452733dba699cd94c38 /configure.ac
parent64471097ca7598e8238f9e5ed25b3afaa9b10f2c (diff)
downloadnasm-eb5b3ae0d3383cef2651ae642ad297bc1dc6f228.tar.gz
nasmlib: Add nasm_(v)asprintf()
Add a version of (v)asprintf(), which allocates a string on the heap. Unlike the standard version of (v)asprintf(), we return the pointer; if one wants the length of the string then one can simply use the %n pattern. Signed-off-by: H. Peter Anvin (Intel) <hpa@zytor.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b2858ec..878b3269 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,8 @@ AC_CHECK_FUNCS(strrchrnul)
AC_CHECK_FUNCS(iscntrl)
AC_CHECK_FUNCS(isascii)
+AC_CHECK_FUNCS(vasprintf)
+
AC_CHECK_FUNCS(getuid)
AC_CHECK_FUNCS(getgid)