summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2019-02-25 21:00:43 -0800
committerH. Peter Anvin <hpa@zytor.com>2019-02-25 21:00:43 -0800
commitefee3ea312358c16190ca5923c495ad8dc9a2547 (patch)
treedd1161b79f58cce36d2f708a78298cebdacc7930 /configure.ac
parent69fa3c2e8e09c1cda8334bec1a7d022cdf877383 (diff)
downloadnasm-efee3ea312358c16190ca5923c495ad8dc9a2547.tar.gz
configure.ac: add --enable-profiling option
Add option to enable profiling without having to modify Makefile. Signed-off-by: H. Peter Anvin <hpa@zytor.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38b3b596..ad724797 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,11 @@ AS_IF([test x"$pa_init_cflags" = x],
AS_IF([test x"$pa_optimize" = "x-O0"],
[PA_ADD_CFLAGS([-fno-omit-frame-pointer])])
+dnl Profiling
+PA_ARG_ENABLED([profiling],
+ [compile with profiling (-pg option)],
+ [PA_ADD_CFLAGS([-pg])])
+
dnl Abort on panic
PA_ARG_ENABLED([panic-abort],
[call abort() on panic to trap in the debugger],