summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8db7c726..8ac4994f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,12 @@ PA_ARG_DISABLED([optimization],
AS_IF([test x"$pa_init_cflags" = x],
[CFLAGS=`echo "$CFLAGS" | sed -e "s/-O2/$pa_optimize/"`])
+dnl Compile and link with dwarf debug
+PA_ARG_ENABLED([gdb],
+ [disable optimization and compile with extra debug information for GDB debugger],
+ [CFLAGS=`echo "$CFLAGS" | sed -e "s/\(-O2\|-O3\)/-O0/"`
+ PA_ADD_CLDFLAGS([-ggdb3])])
+
dnl Check for library extension
PA_LIBEXT