summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRamiro Estrugo <ramiro@src.gnome.org>2000-11-01 03:26:03 +0000
committerRamiro Estrugo <ramiro@src.gnome.org>2000-11-01 03:26:03 +0000
commitbbc1e5427b0bea67b8ab491b71df60c2698e8331 (patch)
treea16e6d74ec3e60e0b15801ed78349a163c99b16f /Makefile.am
parent346ca80df9e94180694be1d363b99b6f4098422b (diff)
downloadnautilus-bbc1e5427b0bea67b8ab491b71df60c2698e8331.tar.gz
Add applets to SUBDIRS if needed.
* Makefile.am: Add applets to SUBDIRS if needed. * applets/Makefile.am: Tiny bit of cleanup. * configure.in: Define HAVE_APPLETS only if the applets devel libs are found by gnome-config.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c5e749a24..b1954a500 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,9 @@
include $(top_srcdir)/Makefile.shared
+if HAVE_APPLETS
+APPLETS_SUBDIRS = applets
+endif
+
SUBDIRS = \
data \
icons \
@@ -12,6 +16,7 @@ SUBDIRS = \
helper-utilities \
src \
components \
+ $(APPLETS_SUBDIRS) \
test \
user-guide \
po \
@@ -49,3 +54,6 @@ install-data-hook: nautilus-clean.sh
$(INSTALL_PROGRAM) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p; \
else :; fi; \
done
+
+caca:
+ @echo $(APPLETS_SUBDIRS)