summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSeth Nickell <seth@eazel.com>2001-02-22 14:21:55 +0000
committerSeth Nickell <seth@src.gnome.org>2001-02-22 14:21:55 +0000
commit2e9551e36205476ef592e80747e90bbc037b3bd3 (patch)
treed0c02905b9623f824baa101994a36366aeb7ca08 /configure.in
parent189835e813bd129c504867aab6c3bba6f5187476 (diff)
downloadnautilus-2e9551e36205476ef592e80747e90bbc037b3bd3.tar.gz
reviewed by: Gene Z. Ragan <gzr@eazel.com>
2001-02-22 Seth Nickell <seth@eazel.com> reviewed by: Gene Z. Ragan <gzr@eazel.com> * acconfig.h: * configure.in: Add various mount system checks. * libnautilus-extensions/nautilus-cdrom-extensions.h: Only do particular #defines for ioctl stuff if the system doesn't already define them. * libnautilus-extensions/nautilus-volume-monitor.c: Add Solaris compatible changes to the volume monitor, making it build and function properly on Solaris.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4b0411484..32c6f1225 100644
--- a/configure.in
+++ b/configure.in
@@ -54,10 +54,22 @@ dnl Check for "RedHat-style" font setup
AM_CONDITIONAL(TYPE1_FONT_DIR_EXISTS, test -d /usr/share/fonts/default/Type1)
dnl Check for different mount systems
-AC_CHECK_FUNCS(setmntent endmntent setenv unsetenv putenv)
-AC_CHECK_HEADERS(sys/mnttab.h sys/vfstab.h)
+echo "
+Determining mount system properties:
+"
+AC_CHECK_FUNCS( setmntent endmntent )
+AC_CHECK_HEADERS( mntent.h sys/mnttab.h sys/vfstab.h sys/cdio.h )
+AC_CHECK_FILES( /dev, AC_DEFINE(HAVE_DEV))
+AC_CHECK_FILES( /vol/dev, AC_DEFINE(HAVE_VOL_DEV))
+AC_CHECK_FILES( /vol, AC_DEFINE(HAVE_VOL))
+AC_CHECK_FILES( /etc/mnttab, AC_DEFINE(HAVE_ETC_MNTTAB))
+AC_CHECK_FILES( /proc/mounts, AC_DEFINE(HAVE_PROC_MOUNTS))
+echo "
+"
+AC_CHECK_FUNCS( setenv unsetenv putenv )
+dnl ====================================
dnl ====================================
dnl = Optionally build the installer