summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSeth Nickell <snickell@stanford.edu>2001-02-23 16:06:09 +0000
committerSeth Nickell <seth@src.gnome.org>2001-02-23 16:06:09 +0000
commit3bd9884061740aae04ab09d7e565fa0a250d3ebf (patch)
tree2e73260c57bb7e0828851b34d54da8ef7c5b46f3 /configure.in
parentb1c1e77c99bcdd672c2a463c5b3479d75b4839bb (diff)
downloadnautilus-3bd9884061740aae04ab09d7e565fa0a250d3ebf.tar.gz
reviewed by: J Shane Culpepper <pepper@eazel.com>
2001-02-23 Seth Nickell <snickell@stanford.edu> reviewed by: J Shane Culpepper <pepper@eazel.com> Fix problems with playing MP3s on Solaris due to our use of Linux/x86-only code pillaged from mpg123. Continue pillaging from mpg123 to grab their generic decoding code for use when we are on non x86/Linux platforms. * configure.in: * components/music/Makefile.am: Check if we are on x86 and only build x86 optimized music components if we are. Otherwise use source & binary compatible generic code. * components/music/decode.c: (mpg123_synth_1to1_8bit), (mpg123_synth_1to1_8bit_mono), (mpg123_synth_1to1_8bit_mono2stereo), (mpg123_synth_1to1_mono), (mpg123_synth_1to1_mono2stereo), (mpg123_synth_1to1): Add decode.c as a generic replacement for decode_i386.c when on non-x86 hardware (dct64.c was already there, just not used), filched from mpg123 same as decode_i386.c. * components/music/mpg123.h: Add one #define to make decode.c happy. Thanks to Niall for nailing this bug :-)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 32c6f1225..7b7cef231 100644
--- a/configure.in
+++ b/configure.in
@@ -53,7 +53,12 @@ dnl ====================================
dnl Check for "RedHat-style" font setup
AM_CONDITIONAL(TYPE1_FONT_DIR_EXISTS, test -d /usr/share/fonts/default/Type1)
-dnl Check for different mount systems
+
+
+dnl ====================================
+dnl = Check for different mount systems
+dnl ====================================
+
echo "
Determining mount system properties:
"
@@ -67,9 +72,23 @@ AC_CHECK_FILES( /proc/mounts, AC_DEFINE(HAVE_PROC_MOUNTS))
echo "
"
+dnl ====================================
+dnl = Method for changing environment
+dnl ====================================
+
AC_CHECK_FUNCS( setenv unsetenv putenv )
+
dnl ====================================
+dnl = Use x86 optimized music routines?
+dnl ====================================
+
+_system_is_x86="no"
+
+AC_CHECK_HEADER( asm/vm86.h, _system_is_x86="yes" )
+
+AM_CONDITIONAL(X86_OPTIMIZED, test "x$_system_is_x86" = "xyes")
+
dnl ====================================
dnl = Optionally build the installer