summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMaciej Stachowiak <mstachow@src.gnome.org>2000-04-19 13:11:41 +0000
committerMaciej Stachowiak <mstachow@src.gnome.org>2000-04-19 13:11:41 +0000
commitf6e6b4711074fbd012312bb76ec4874fce0f7976 (patch)
treede6c8b8bbdaab0f3b3f6a14aed3091c01454dc9a /configure.in
parenta3a3e671d1e97662b41b4115f50f616071665ef0 (diff)
downloadnautilus-f6e6b4711074fbd012312bb76ec4874fce0f7976.tar.gz
OAF conversion. You must now build bonobo and gnome-vfs with --enable-oaf
OAF conversion. You must now build bonobo and gnome-vfs with --enable-oaf * configure.in: Check for OAF * libnautilus/nautilus-view-component.idl: Inherit from Bonobo::Unknown instead of GNOME::Unknown. * libnautilus-extensions/nautilus-global-preferences.c, libnautilus-extensions/nautilus-global-preferences.h: Refer to meta views by OAFIID, not GOAD ID. * src/ntl-uri-map.c (my_notify_when_ready): Replaced hardcoded list of GOAD IDs with a hardcoded list of OAFIIDs. (add_components_from_metadata): Changed the expected format; it is now label=component instead of component:label since OAFIIDs contain colons. * src/ntl-view.c (nautilus_view_destroy_client): unref the Zoomable interface of the View, if any. * src/file-manager/dfos-corba.c, src/file-manager/dfos.c: replace GOAD calls with OAF ones; untested since this code is not really used right now. * src/ntl-main.c: Use OAF calls to intialize CORBA. * src/ntl-app.c: Replace GOAD IDs with OAFIIDs. Use Bonobo_Generic_Factory instead of GNOME_Generic_Factory to make the linker happy. Register the factory server with OAF, not GOAD. * src/nautilus.h: Include <liboaf/liboaf.h> instead of <libgnorba/gnorba.h> * components/help/Makefile.am, components/history/Makefile.am, components/html/Makefile.am, components/mozilla/Makefile.am, components/music/Makefile.am, components/notes/Makefile.am, components/rpmview/Makefile.am, components/sample/Makefile.am, components/services/startup/Makefile.am, components/websearch/Makefile.am, libnautilus/Makefile.am, libnautilus-extensions/Makefile.am, src/Makefile.am, src/file-manager/Makefile.am: Updated for OAF; install .oafinfo files instead of .gnorba. * components/help/hyperbola-main.c, components/history/ntl-history-view.c, components/html/ntl-web-browser.c, components/mozilla/main.c, components/music/main.c, components/notes/ntl-notes.c, components/rpmview/main.c, components/sample/main.c, components/services/startup/main.c, components/websearch/ntl-web-search.c: Convert to OAF; use OAFIIDs and oaf intialization functions. * src/nautilus.oafinfo, components/help/hyperbola.oafinfo, components/history/ntl-history-view.oafinfo, components/html/ntl-web-browser.oafinfo, components/music/nautilus-music-view.oafinfo, components/notes/ntl-notes.oafinfo, components/rpmview/nautilus-rpm-view.oafinfo, components/services/startup/nautilus-service-startup-view.oafinfo, components/websearch/ntl-web-search.oafinfo, components/sample/nautilus-sample-content-view.oafinfo, components/mozilla/nautilus-mozilla-content-view.oafinfo: New OAF activation records. * src/nautilus.goad, components/help/hyperbola.goad, components/history/ntl-history-view.goad, components/html/ntl-web-browser.goad, components/music/nautilus-music-view.goad, components/notes/ntl-notes.goad, components/rpmview/nautilus-rpm-view.goad, components/services/startup/nautilus-service-startup-view.goad, components/websearch/ntl-web-search.goad, components/sample/nautilus-sample-content-view.goad, components/mozilla/nautilus-mozilla-content-view.goad: Removed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 839726946..06b3fb3ab 100644
--- a/configure.in
+++ b/configure.in
@@ -212,6 +212,16 @@ gnomelocaledir='${prefix}/${DATADIRNAME}/locale'
AC_SUBST(gnomelocaledir)
+dnl Check for OAF
+
+
+dnl Check for OAF
+
+AC_PATH_PROG(OAF_CONFIG,oaf-config,no)
+
+OAF_LIBS=`$OAF_CONFIG --libs`
+OAF_CFLAGS=`$OAF_CONFIG --cflags`
+
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST