summaryrefslogtreecommitdiff
path: root/libnautilus-extensions/Makefile.am
diff options
context:
space:
mode:
authorJohn Harper <jsh@eazel.com>2001-03-02 23:58:14 +0000
committerJohn Harper <jsh@src.gnome.org>2001-03-02 23:58:14 +0000
commit6ab518bc39438b1abb14022e4c7c225c37cb1025 (patch)
tree7b493d154ada68ed19a83b6071ec41c84226f0f3 /libnautilus-extensions/Makefile.am
parent15ebdc1143d9fa561087d83c3e3d782958facf0a (diff)
downloadnautilus-6ab518bc39438b1abb14022e4c7c225c37cb1025.tar.gz
reviewed by: Darin Adler <darin@eazel.com>
2001-03-02 John Harper <jsh@eazel.com> reviewed by: Darin Adler <darin@eazel.com> Work to cache smooth-text-layout objects. This increases the speed of aa rendering so that there's no noticeable difference when compared with non-aa mode (e.g. when dragging windows over the top of the nautilus window) * libnautilus-extensions/nautilus-smooth-text-layout-cache.c, libnautilus-extensions/nautilus-smooth-text-layout-cache.h: new class, a cache for the NautilusSmoothTextLayout objects * libnautilus-extensions/nautilus-icon-canvas-item.c (nautilus_icon_canvas_item_initialize_class): allocate a NautilusSmoothTextLayoutCache for all canvas items. It will be freed on program exit (draw_or_measure_label_text_aa): use the layout cache when rendering text * libnautilus-extensions/Makefile.am: added layout cache files * libnautilus-extensions/nautilus-glyph.c, libnautilus-extensions/nautilus-glyph.c, libnautilus-extensions/nautilus-smooth-text-layout.c, libnautilus-extensions/nautilus-smooth-text-layout.c (nautilus_glyph_compare, nautilus_smooth_text_layout_compare): new functions, only defined when NAUTILUS_OMIT_SELF_CHECK isn't #define'd. Used by the cache's self test code * libnautilus-extensions/nautilus-lib-self-check-functions.h: added nautilus_self_check_smooth_text_layout_cache to the list
Diffstat (limited to 'libnautilus-extensions/Makefile.am')
-rw-r--r--libnautilus-extensions/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libnautilus-extensions/Makefile.am b/libnautilus-extensions/Makefile.am
index a7e22caa8..9b8f4f36e 100644
--- a/libnautilus-extensions/Makefile.am
+++ b/libnautilus-extensions/Makefile.am
@@ -142,6 +142,7 @@ libnautilus_extensions_la_SOURCES = \
nautilus-search-uri.c \
nautilus-self-checks.c \
nautilus-smooth-text-layout.c \
+ nautilus-smooth-text-layout-cache.c \
nautilus-smooth-widget.c \
nautilus-sound.c \
nautilus-stock-dialogs.c \
@@ -266,6 +267,7 @@ noinst_HEADERS = \
nautilus-search-uri.h \
nautilus-self-checks.h \
nautilus-smooth-text-layout.h \
+ nautilus-smooth-text-layout-cache.h \
nautilus-smooth-widget.h \
nautilus-sound.h \
nautilus-stock-dialogs.h \