summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNishal Kulkarni <nishalkulkarni@gmail.com>2021-12-04 17:37:35 +0530
committerAntónio Fernandes <antoniojpfernandes@gmail.com>2021-12-04 22:54:14 +0000
commit0dfaaaeecddef60bb37955c6db5027396ff2f623 (patch)
treeb83ac8ec6dce664e2a64b905e6f286e5c96d4d65 /meson.build
parentb7b475298cad315da3c0ad159e497abc0bfe1993 (diff)
downloadnautilus-0dfaaaeecddef60bb37955c6db5027396ff2f623.tar.gz
extensions/image-properties: Replace deprecated functions
Build log contains deprecation warnings for gexiv2 functions. Replaced `gexiv2_metadata_has_tag()` with `gexiv2_metadata_try_has_tag()` and `gexiv2_metadata_get_orientation()` with `gexiv2_metadata_try_get_orientation()` Closes: #2033
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b52694658..927216636 100644
--- a/meson.build
+++ b/meson.build
@@ -109,7 +109,7 @@ libgd_dep = libgd.get_variable('libgd_dep')
libm = cc.find_library('m')
if get_option('extensions')
- gexiv = dependency('gexiv2', version: '>= 0.12.2')
+ gexiv = dependency('gexiv2', version: '>= 0.14.0')
gst_tag_dep = dependency('gstreamer-tag-1.0')
gst_pbutils_dep = dependency('gstreamer-pbutils-1.0')
endif