summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJeremy Bicha <jeremy.bicha@canonical.com>2022-05-26 15:19:04 -0400
committerJeremy Bicha <jeremy.bicha@canonical.com>2022-05-26 15:19:04 -0400
commit794931998cb27b7ca94651c72300a5ed167a8951 (patch)
treea8a1e0f190c615199307c8248fed0ba3ee128bfb /meson.build
parent50da8a18605cbbf7cd179f0b96a9478eb8f3853c (diff)
downloadnautilus-794931998cb27b7ca94651c72300a5ed167a8951.tar.gz
Drop libportal option
This is a follow up from https://gitlab.gnome.org/GNOME/nautilus/-/commit/6af38c29d As a result of that commit, it's not possible to set a picture as desktop wallpaper from Nautilus unless libportal is used. Since libportal is generally available, it's no longer a useful option to not use libportal.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 2 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index e9ec2b856..154c7b763 100644
--- a/meson.build
+++ b/meson.build
@@ -109,12 +109,8 @@ gnome_autoar = dependency('gnome-autoar-0', version: '>= 0.4.0')
gnome_desktop = dependency('gnome-desktop-4', version: '>= 43')
gtk = dependency('gtk4', version: '>= 4.6')
libadwaita = dependency('libadwaita-1', version: '>= 1.0')
-libportal = []
-libportal_gtk4 = []
-if get_option('libportal')
- libportal = dependency('libportal', version: '>= 0.5')
- libportal_gtk4 = dependency('libportal-gtk4', version: '>= 0.5')
-endif
+libportal = dependency('libportal', version: '>= 0.5')
+libportal_gtk4 = dependency('libportal-gtk4', version: '>= 0.5')
selinux = []
if get_option('selinux')
selinux = dependency('libselinux', version: '>= 2.0')
@@ -160,7 +156,6 @@ conf.set_quoted('VERSION', version_string)
conf.set('ENABLE_PACKAGEKIT', get_option('packagekit'))
conf.set('ENABLE_PROFILING', get_option('profiling'))
-conf.set('HAVE_LIBPORTAL', get_option('libportal'))
conf.set('HAVE_SELINUX', get_option('selinux'))
#############################################################