summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCorey Berla <corey@berla.me>2023-01-09 12:12:32 -0800
committerOndrej Holy <oholy@redhat.com>2023-01-16 12:11:25 +0000
commitdac56fcab6d7101992789987047572f0ac86478a (patch)
tree27dff133c7ae30c570316f9bf2f5ec1fdc604113 /meson.build
parent21c79c06d5893a34ad22948b1464e9c7b09e5341 (diff)
downloadnautilus-dac56fcab6d7101992789987047572f0ac86478a.tar.gz
build: Only generate docs when 'docs' option enabled
We have a docs options, but we are generating the docs regardless of if it is set. This was a regression in d47403bcede0f331c04c7fb28cec2583fed16724. `gi_docgen.found()` is redundant because when 'docs' is set to true gi_docgen is a requirement.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fa0d7a97d..48e4e4e80 100644
--- a/meson.build
+++ b/meson.build
@@ -198,7 +198,7 @@ subdirs = [
# Conditional building #
########################
-if gi_docgen.found()
+if get_option('docs')
subdirs += 'docs'
endif
if get_option('tests') != 'none'