summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 996360a62..3db1dcaf6 100644
--- a/meson.build
+++ b/meson.build
@@ -137,6 +137,8 @@ tracker_sparql = dependency('tracker-sparql-2.0')
x11 = dependency('x11')
xml = dependency('libxml-2.0', version: '>= 2.7.8')
+fontconfig = dependency('fontconfig', required: false)
+
####################
# End dependencies #
####################
@@ -159,6 +161,12 @@ endif
application_id = 'org.gnome.Nautilus' + profile
+if fontconfig.found()
+ fontconfig_cache_path = fontconfig.get_pkgconfig_variable('cachedir')
+else
+ fontconfig_cache_path = join_paths(libdir, 'fontconfig/cache')
+endif
+
conf.set_quoted('APPLICATION_ID', application_id)
conf.set_quoted('GETTEXT_PACKAGE', 'nautilus')
conf.set_quoted('INSTALL_PREFIX', prefix)
@@ -169,6 +177,7 @@ conf.set_quoted('NAUTILUS_EXTENSIONDIR', join_paths(prefix, extensiondir))
conf.set_quoted('PACKAGE_VERSION', meson.project_version())
conf.set_quoted('PROFILE', profile)
conf.set_quoted('VERSION', '@0@-@VCS_TAG@'.format(meson.project_version()))
+conf.set_quoted('FONTCONFIG_CACHE_PATH', fontconfig_cache_path)
###################################################
# gnome-desktop macros for thumbnailer sandboxing #