summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-08-02 19:48:58 +0000
committermdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-08-02 19:48:58 +0000
commit1897f25a9591b0a4a9045d359613fc7cff51c70a (patch)
tree9e230e2e03e560ca6e0a4ea02a3c2ca4ebdbc563 /CMakeLists.txt
parent884e24655efae377b297e1ddbdee902b45bcf5c1 (diff)
downloadnavit-svn-1897f25a9591b0a4a9045d359613fc7cff51c70a.tar.gz
Fix:core:Remove duplicate code imported with r5539. Refix the win* "Dollar S" announcement bug with already imported libintl implementations of the proper printf.
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5554 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e218d60..1232661c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -175,6 +175,7 @@ CHECK_FUNCTION_EXISTS(fsync HAVE_FSYNC)
if (NOT HAVE_LIBINTL)
add_plugin(intl_cmake "native libintl missing" TRUE)
set(USE_LIBGNUINTL TRUE)
+ include_directories("${CMAKE_BINARY_DIR}/navit/intl_cmake")
else()
CHECK_LIBRARY_EXISTS(intl libintl_fprintf "" NEEDS_LIBINTL)
if (NEEDS_LIBINTL)
@@ -492,7 +493,6 @@ if(WIN32 OR WINCE)
enable_language(RC)
set(XSLTS "windows;${XSLTS}" CACHE STRING "define a semicolon seperated list of XSLTs to process")
- set(GLIB_USE_OWN_PRINTF 1)
endif()
if (WIN32 AND NOT WINCE)
set(HAVE_PRAGMA_PACK 1)