summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorakashihi <akashihi@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-08 12:14:11 +0000
committerakashihi <akashihi@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-08 12:14:11 +0000
commit6df15b73db8257a237dd2c2aeb1887b7d2515181 (patch)
tree762331a57643cb7b60abc6628b59c4cdc636c81f /CMakeLists.txt
parent6a6083202c06135de1bbe90b11ed3b7463383bc9 (diff)
downloadnavit-svn-6df15b73db8257a237dd2c2aeb1887b7d2515181.tar.gz
Fix:build:Added building of speech_cmdline with cmake
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4600 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 040eaaba..a99d0588 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,7 @@ add_module(vehicle/gypsy "gypsy lib not found" FALSE)
add_module(vehicle/maemo "Default" FALSE)
add_module(binding/dbus "dbus-glib-1 not found" FALSE)
add_module(speech/dbus "dbus-glib-1 not found" FALSE)
+add_module(speech/cmdline "neither system() nor CreateProcess() found" FALSE)
add_module(vehicle/gpsd_dbus "dbus-glib-1 not found" FALSE)
add_module(speech/speech_dispatcher "speech_dispatcher lib not found" FALSE)
add_module(autoload/osso "Default" FALSE)
@@ -110,6 +111,9 @@ CHECK_INCLUDE_FILES(sys/time.h HAVE_SYS_TIME_H)
CHECK_INCLUDE_FILES(getopt.h HAVE_GETOPT_H)
CHECK_INCLUDE_FILES(string.h HAVE_STRING_H)
CHECK_FUNCTION_EXISTS(gettimeofday HAVE_GETTIMEOFDAY)
+CHECK_SYMBOL_EXISTS(system stdlib.h HAVE_SYSTEM)
+CHECK_SYMBOL_EXISTS(CreateProcess windows.h HAVE_CREATEPROCESS)
+
### Configure build
#Required libraries, supplied with navit
@@ -262,6 +266,14 @@ if (HAVE_LIBSPEECHD)
set_with_reason(speech/speech_dispatcher "speech_dispatcher lib found" TRUE speechd)
endif(HAVE_LIBSPEECHD)
+if (HAVE_SYSTEM)
+ set_with_reason(speech/cmdline "system() call is available" TRUE)
+endif(HAVE_SYSTEM)
+
+if (HAVE_CREATEPROCESS)
+ set_with_reason(speech/cmdline "CreateProcess() call is available" TRUE)
+endif(HAVE_CREATEPROCESS)
+
if (GETTEXT_FOUND)
execute_process(COMMAND echo "<test/>" COMMAND xgettext -L glade - RESULT_VARIABLE GETTEXT_RET)
if ("${GETTEXT_RET}" STREQUAL "0")