summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsleske <sleske@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-09-15 18:58:31 +0000
committersleske <sleske@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-09-15 18:58:31 +0000
commit7287b435c1c7feb271323ffcf07931bd10f74b80 (patch)
treec91cd6c05395af986fe18ef02282455ca3bb7823 /CMakeLists.txt
parentc58107149a35f2e0984c9b398caa4e0aad3b8b3d (diff)
downloadnavit-svn-7287b435c1c7feb271323ffcf07931bd10f74b80.tar.gz
Fix:vehicle_gpsd:Require libgps V3.1+, drop compatibility #ifdefs and warning about LC_ALL.|Fixes #850.
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5642 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c8e3f72..32b6e5ae 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,10 +131,9 @@ endif (NOT DISABLE_QT)
find_package(PkgConfig)
if(PKG_CONFIG_FOUND)
pkg_check_modules(QUESOGLC quesoglc)
- pkg_check_modules(LIBGPS libgps)
pkg_check_modules(LIBLOCATION liblocation)
pkg_check_modules(LIBOSSO libosso)
- pkg_check_modules(LIBGPS19 libgps>=2.90)
+ pkg_check_modules(LIBGPS libgps>=3.1) # libgpsd<V3.1 is buggy if LC_ALL is set.
pkg_check_modules(LIBGARMIN libgarmin)
pkg_check_modules(IMLIB2 imlib2)
if(IMLIB2_FOUND)