summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrikky <rikky@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-09-06 19:25:02 +0000
committerrikky <rikky@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-09-06 19:25:02 +0000
commitdaf539c33877a47c5b4a336dfeb74423e6d736f5 (patch)
tree62aaac8ec9504fdeb362e6f10bbfae4e4de14e69 /CMakeLists.txt
parent3912c3e533ecbc94332ed0e5bf70781aef386c57 (diff)
downloadnavit-svn-daf539c33877a47c5b4a336dfeb74423e6d736f5.tar.gz
Fix:android:Fix for using plugins with API 3 (Android 1.5)
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4764 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18cbf808..5fc59e57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -468,6 +468,9 @@ if (SAMPLE_MAP)
endif(SAMPLE_MAP)
if(ANDROID)
+ # for android API 3 compatiblity
+ SET(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "-Wl,-soname,/data/data/org.navitproject.navit/lib/")
+
find_program(ANDROID_LOCATION NAMES android android.bat)
find_program(ANT_LOCATION NAMES ant)
if (NOT ANT_LOCATION)