summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsleske <sleske@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-06-14 18:50:24 +0000
committersleske <sleske@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-06-14 18:50:24 +0000
commite5ece4739894651a13fd9cd801aff27543d53e62 (patch)
treea58d440adeac7780f8acf9fea53db18919a2e06c /CMakeLists.txt
parentecc41e97ec2d54bbbcc2251ef85c1b5952aa230a (diff)
downloadnavit-svn-e5ece4739894651a13fd9cd801aff27543d53e62.tar.gz
Fix:build/cmake:Make CMake variable ENABLE_NLS work.
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5536 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34cbe712..4ab76ff3 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,7 +95,7 @@ add_module(vehicle/gpsd_dbus "dbus-glib-1 not found" FALSE)
add_module(speech/speech_dispatcher "speech_dispatcher lib not found" FALSE)
add_module(autoload/osso "Default" FALSE)
add_module(map/garmin "Garmin library not found" FALSE)
-add_feature(ENABLE_NLS "default" TRUE)
+add_feature(ENABLE_NLS "Gettext not found and not on Windows" FALSE)
INCLUDE (CPack)
INCLUDE (CheckIncludeFiles)
@@ -352,6 +352,10 @@ if (LIBOSSO_FOUND)
set_with_reason(autoload/osso "Maemo osso library found" TRUE ${LIBOSSO_LIBRARIES})
endif(LIBOSSO_FOUND)
+if (GETTEXT_FOUND)
+ set_with_reason(ENABLE_NLS "Gettext found" TRUE)
+endif(GETTEXT_FOUND)
+
#Independent modules
add_module(graphics/null "Default" TRUE)
add_module(osd/core "Default" TRUE)
@@ -484,7 +488,7 @@ if(WIN32 OR WINCE)
set(HAVE_PRAGMA_PACK 1)
add_plugin(support/xgetopt "Windows detected" TRUE)
endif(MSVC)
- set(ENABLE_NLS TRUE)
+ set_with_reason(ENABLE_NLS "Windows detected" TRUE)
enable_language(RC)
set(XSLTS "windows;${XSLTS}" CACHE STRING "define a semicolon seperated list of XSLTs to process")
@@ -690,6 +694,6 @@ add_subdirectory (navit)
add_subdirectory (man)
-if (GETTEXT_FOUND)
+if (ENABLE_NLS)
add_subdirectory (po)
-endif(GETTEXT_FOUND)
+endif(ENABLE_NLS)