summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-08-27 07:37:56 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-08-27 07:37:56 +0000
commite78f897e7313559d6eeb50df0e526860d02861c8 (patch)
tree26f9d4d3255476874e60c49d9ff02adc8f87f53f /CMakeLists.txt
parentaf330660edf31539053e9b09ae426af6c9a14d03 (diff)
downloadnavit-svn-e78f897e7313559d6eeb50df0e526860d02861c8.tar.gz
Add:Build:Enable binding_python for cmake builds
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5612 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6d52c539..89643d47 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,6 +89,7 @@ add_module(vehicle/gypsy "gypsy lib not found" FALSE)
add_module(vehicle/maemo "Default" FALSE)
add_module(binding/win32 "Default" FALSE)
add_module(binding/dbus "dbus-glib-1 not found" FALSE)
+add_module(binding/python "python libraries not found" FALSE)
add_module(speech/dbus "dbus-glib-1 not found" FALSE)
add_module(speech/cmdline "neither system() nor CreateProcess() found" FALSE)
add_module(vehicle/gpsd_dbus "dbus-glib-1 not found" FALSE)
@@ -115,6 +116,7 @@ find_package(GTK2 2.6 COMPONENTS gtk)
find_package(XGettextGlade)
find_package(PNG)
find_package(DBusGLib)
+find_package(PythonLibs)
find_package(OpenSSL)
find_package(Threads)
libfind_pkg_check_modules(FONTCONFIG fontconfig)
@@ -334,6 +336,10 @@ if(DBusGLib_FOUND)
set_with_reason(vehicle/gpsd_dbus "dbus-glib-1 found" TRUE ${DBusGLib_LIBRARIES})
endif()
+if(PYTHONLIBS_FOUND)
+ set_with_reason(binding/python "python libraries [${PYTHONLIBS_VERSION_STRING}] found" TRUE ${PYTHON_LIBRARIES})
+endif()
+
if (HAVE_LIBSPEECHD)
set_with_reason(speech/speech_dispatcher "speech_dispatcher lib found" TRUE speechd)
endif(HAVE_LIBSPEECHD)